Turnitin.com and TurnitinUK.com unavailable
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service outage, users of Turnitin and TurnitinUK may have been unable to access Turnitin’s grading services and/or were shown a 503 error when attempting to log in to our main site.

We are however pleased to advise that service has been restored.

We encountered a disruption between the following times:

PDT September 2nd, 2021 - September 2nd, 2021 2:36 PM to 4:40
BST September 2nd, 2021 - September 3rd, 2021 22:23 PM to 00:40
AEST September 3rd 2021 - September 3rd, 2021 07:23 AM to 09:40

Please accept our apologies if you were impacted by today’s disruption.
Posted Sep 02, 2021 - 16:54 PDT
Identified
Our engineers have identified the issue and are working on releasing a fix for this incident. Thank you for your continued patience. For updates, please visit https://turnitin.statuspage.io/
Posted Sep 02, 2021 - 16:37 PDT
Investigating
We’ve run into some issues.

Turnitin.com and Turnitinuk.com are currently experiencing an unexpected service disruption.

During this time, you may find that users are unable to access either service and are shown a 503 error when attempting to access the login page or main site.

We invite you to track the progress of this disruption while we work to bring the service back to optimum health.
Posted Sep 02, 2021 - 16:04 PDT
This incident affected: Turnitin (Turnitin.com, Turnitin Logins, Turnitin Paper Submissions, Turnitin Report Processing Time, Turnitin Feedback Studio Access, Turnitin Feedback Studio Grading Access) and Turnitin UK (Turnitinuk.com, Turnitin UK Logins, Turnitin UK Paper Submissions, Turnitin UK Report Processing Time, Turnitin UK Feedback Studio Access, Turnitin UK Feedback Studio Grading Access).