Turnitin Status Notification
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service degradation, users of Turnitin, Turnitin UK, iThenticate, SimCheck, Similarity and Originality, as well as those accessing the service via an integration, may have experienced issues receiving Similarity Reports in addition to slow report generation times.

We are pleased to advise that service has been restored. We encountered a degradation between the following times:
PST Nov 04 04:45 - Nov 06 15:36
GMT Nov 04 12:45 - Nov 06 23:36
AEST Nov 04 23:45 - Nov 07 10:36

Please accept our apologies if you were impacted by this disruption.
Posted Nov 06, 2020 - 16:45 PST
Update
We believe that report generation times have now returned to normal for users accessing SimCheck, Similarity and Originality in Europe. However, some Turnitin and Turnitin UK users may still be experiencing degraded report generation times, due to the backlog created by a recent incident. We are continuing to monitor for any further issues.
Posted Nov 06, 2020 - 13:28 PST
Update
We believe that report generation times are returning to normal for users of Turnitin, Turnitin UK, as well as those accessing SimCheck, Similarity and Originality in Europe. However, some users may still be experiencing degraded report generation times, due to the backlog created by yesterday's incident. We are continuing to monitor for any further issues.
Posted Nov 06, 2020 - 10:20 PST
Update
We believe that report generation times have returned to normal for users of iThenticate and users accessing SimCheck, Similarity and Originality in the Americas and Asia Pacific regions. However, some users accessing Turnitin & Turnitin UK, as well as those accessing SimCheck, Similarity and Originality in Europe may still be experiencing degraded report generation times, due to the backlog created by yesterday’s incident.
Posted Nov 06, 2020 - 09:36 PST
Update
We are continuing to monitor for any further issues. However, some users may still be experiencing degraded report generation times, due to the backlog created by yesterday's incident.
Posted Nov 06, 2020 - 07:37 PST
Update
We believe that report generation times are returning to normal. However, some users may still be experiencing degraded report generation times, due to the backlog created by yesterday's incident.
Posted Nov 06, 2020 - 07:09 PST
Update
We are continuing to monitor for any further issues.
Posted Nov 05, 2020 - 09:33 PST
Monitoring
Turnitin.com, Turnitinuk.com, iThenticate, SimCheck, Similarity and Originality, are currently experiencing an unexpected service degradation. We believe we have resolved the issue, and we are continuing to monitor the situation.
Users will still continue to experience slow report generation during this time, while we process the backlog of submissions.
Posted Nov 05, 2020 - 06:27 PST
Identified
We’ve run into some issues.

Turnitin.com, TurnitinUK.com, iThenticate, SimCheck, Similarity and Originality are currently experiencing an unexpected service degradation.

During this time, you may find that Similarity Reports are not generating.

Those accessing these services via an integration may also be impacted.

We invite you to track the progress of this disruption while we work to bring the service back to optimum health.
Posted Nov 05, 2020 - 02:50 PST
This incident affected: iThenticate (iThenticate Report Processing Time), Americas (US environment) (Report Processing Time), Europe (EU environment) (Report Processing Time), Asia Pacific (Asia Pacific environment) (Report Processing Time), Turnitin (Turnitin Report Processing Time), and Turnitin UK (Turnitin UK Report Processing Time).