Unexpected Service Disruption
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service disruption, users of Turnitin Similarity, SimCheck, Originality, and Crossref Similarity Check accessing these services via an integration may have been unable to make submissions, view assignments, or receive Similarity Reports today.

Users of Turnitin Draft Coach may also have been unable to make submissions or log in during this time.

We are pleased to advise that service has been restored.

The incident occurred between the following times:

PDT October 1st 09:39 - October 1st 11:02
BST October 1st 17:39 - October 1st 19:02
AEST October 2nd 02:39 - October 2nd 04:02

Please accept our apologies if you were impacted by today’s incident.
Posted Oct 01, 2021 - 11:23 PDT
Investigating
We’ve run into some issues.

Turnitin Similarity, SimCheck, Originality, and Crossref Similarity Check are currently experiencing an unexpected service disruption.

During this time, users may find that they are unable to make submissions, view assignments, or receive Similarity Reports when accessing these services via an integration. Users of Turnitin Draft Coach may also find they are unable to log in or make submissions.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Oct 01, 2021 - 10:40 PDT
This incident affected: Americas (US environment) (API) and Crossref Similarity Check ((v2) API).