Due to an unexpected service incident, you may have been unable to access Turnitin Clarity assignments created using an LTI 1.3 integration via turnitinuk.com and turnitin.com directly today.
We are pleased to advise that service has been restored.
The incident occurred between the following times:
PDT: Thursday, 30th April 08:47- Thursday, 30th April 14:01 BST: Thursday, 30th April 16:47 - Thursday, 30th April 22:01 AEST: Friday, 1st May 01:47 - Friday, 1st May 07:01
We regret any inconvenience this may have caused if you were impacted by today’s incident.
Posted Apr 30, 2026 - 14:36 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 30, 2026 - 12:31 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 30, 2026 - 12:30 PDT
Identified
We’ve run into some issues.
Turnitin Clarity is currently experiencing an unexpected service incident.
During this time, you may find that you areunable to access Turnitin Clarity assignments created using an LTI 1.3 integration via turnitinuk.com and turnitin.com directly.
We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Apr 30, 2026 - 11:29 PDT
This incident affected: Turnitin (Turnitin Clarity).