Slowness accessing SimCheck, Similarity and Originality in Europe
Incident Report for Turnitin
Resolved
We’ve fixed it!

Some users accessing SimCheck, Similarity and Originality as well as those accessing these services via an integration in Europe may have experienced some slowness.

We are pleased to advise that service has been restored.

We encountered a disruption between the following times:

PDT Wed, 24 Mar 2021 3:58 PM - 5:25 PM
GMT  Wed, 24 Mar 2021 10:58 PM - Thur 25 Mar 2021 12:25 AM
AEDT Thu, 25 Mar 2021 9:58 AM - 11:25 AM

Please accept our apologies if you were impacted by today’s disruption.
Posted Mar 24, 2021 - 18:14 PDT
Investigating
Some users accessing SimCheck, Similarity and Originality in Europe may experience some slowness. Users accessing these services via an integration may also be impacted.

We are continuing to monitor for any further issues.

We apologize for any inconvenience this may cause.
Posted Mar 24, 2021 - 17:48 PDT
This incident affected: Europe (EU environment) (Paper Submissions, Report Processing Time).