Issue with access and submission
Incident Report for Turnitin
Resolved
Due to an unexpected degradation, users may have been unable to submit and experienced delays in report generation through Turnitin, Turnitin UK and iThenticate today. Users accessing these services via an integration would also have been impacted. We are pleased to advise that service has been restored.

We encountered a disruption between the following times:

PDT April 26th 20:17 - April 27th 01:40
BST April 27th 04:17 - April 27th 09:40
AEST April 27th 13:17 - April 27th 18:40

Please accept our apologies if you were impacted by today's disruption.
Posted Apr 27, 2020 - 02:59 PDT
Update
We have resolved the issue where users were unable to submit to these services. A fix has been implemented to resolve the issue with slow report generation times however we currently have a backlog of reports waiting to be generated. We will update you as soon as this backlog has been cleared.
Posted Apr 27, 2020 - 00:58 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 26, 2020 - 23:34 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 26, 2020 - 22:34 PDT
Update
We are continuing to investigate this issue.
Posted Apr 26, 2020 - 22:21 PDT
Update
We are continuing to investigate this issue.
Posted Apr 26, 2020 - 21:04 PDT
Investigating
We’ve run into some issues.

Turnitin and TurnitinUK are currently experiencing an unexpected service disruption.

During this time, you may find that you can't access and submit.

We invite you to track the progress of this disruption while we work to bring service back to optimum health.
Posted Apr 26, 2020 - 20:56 PDT
This incident affected: iThenticate (iThenticate Report Processing Time), Turnitin UK (Turnitin UK Paper Submissions, Turnitin UK Report Processing Time), and Turnitin (Turnitin Paper Submissions, Turnitin Report Processing Time, Turnitin Feedback Studio Access).