Delayed Similarity Report generation
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service degradation, you may have found that you were unable to submit files or that you experienced a delay in Similarity Report generation. We are pleased to advise that service has been restored.

The incident occurred between the following times:

PST: March 22nd 03:38 - March 22nd 04:56
GMT: March 22nd 10:38 - March 22nd 11:56
AEDT: March 22nd 21:38 - March 22nd 22:56

Please accept our apologies if you were impacted by today’s incident.
Posted Mar 22, 2022 - 05:06 PDT
Monitoring
We’ve run into some issues.

Turnitin and Turnitin UK experienced an unexpected service incident.

During this time, you may find that you were unable to submit documents or documents that were submitted experienced delayed Similarity Report generation times.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Mar 22, 2022 - 04:09 PDT
This incident affected: Turnitin UK (Turnitin UK Paper Submissions, Turnitin UK Report Processing Time) and Turnitin (Turnitin Paper Submissions, Turnitin Report Processing Time).