Issue with Evaluation Viewer responding slowly
Incident Report for Turnitin
Resolved
There are problems with the Evaluation Viewer service - we are investigating the issue.

We have identified the problem, and are working on a solution.

The issue with the evaluation viewer has been resolved. Thank you for your patience.
Posted Dec 07, 2018 - 07:15 PST