Due to an unexpected service incident, users of Turnitin, Turnitin UK, Turnitin Draft Coach, iThenticate, Crossref, Turnitin Similarity, Originality, and Simcheck, and those accessing the service via an integration may have experienced delays in Similarity Report generation.
We are pleased to advise that the incident has been resolved. The incident occurred between the following times:
PST: December 8th, 20:24 - December 9th, 02:46 GMT: December 9th, 04:24 - December 9th, 10:46 AEDT: December 9th, 15:24 - December 9th, 21:46
We regret any inconvenience this may have caused if today’s incident impacted you.
Posted Dec 09, 2024 - 03:37 PST
Update
The report generation incident impacting the following services Draft Coach, iThenticate, Crossref, Turnitin Similarity, Originality, and Simcheck, has now been resolved.
A fix has been implemented, and we are monitoring the results. We continue to work through the backlog from the incident affecting Turnitin and Turnitin UK.
Posted Dec 09, 2024 - 02:20 PST
Monitoring
A fix has been implemented and we are monitoring the results. We continue to work through the backlog from the incident.
Posted Dec 09, 2024 - 01:46 PST
Identified
We’ve run into some issues.
Turnitin, Turnitin UK, Draft Coach, iThenticate, Crossref, Turnitin Similarity, Originality, and Simcheck are currently experiencing an unexpected service incident. Users accessing these services through integrations may also be impacted.
During this time, you may experience delays in Similarity Report generation.
We invite you to track the progress of this incident while we work to bring the service back to optimum health.