Due to an unexpected service incident, users of Turnitin Feedback Studio may have intermittently found that Similarity Reports were stuck processing, or experienced issues in downloading a copy of a Similarity Report and/or digital receipt. Users accessing the service via an integration may also have been affected. We are pleased to advise that service has been restored.
The incident occurred between the following times:
BST: August 5, 16:59 - August 9, 17:15 PDT: August 5, 08:59 - August 9, 09:15 AEST: August 6, 01:59 - August 10, 02:15
We regret any inconvenience this may have caused if you were impacted by today’s incident.
Posted Aug 09, 2024 - 09:44 PDT
Identified
We’ve run into some issues.
Turnitin Feedback Studio is currently experiencing an unexpected service incident.
During this time, you may intermittently find that Similarity Reports are stuck processing, or experience issues in downloading a copy of a Similarity Report and/or digital receipt.
Users accessing the service via an integration may also be affected.
We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Aug 09, 2024 - 08:27 PDT
This incident affected: Turnitin (Turnitin Report Processing Time, Turnitin Feedback Studio Access) and Turnitin UK (Turnitin UK Report Processing Time, Turnitin UK Feedback Studio Access).