Turnitin Service Incident - 12th November 2024
Incident Report for Turnitin
Resolved
We've fixed it!

Turnitin and Turnitin UK experienced an unexpected service incident.

Users may have been unable to access the QuickMark manager or view QuickMarks.

The incident occurred between the following times:

PST: November 12th 11:05 - November 12th 12:13
GMT: November 12th 19:05 - November 12th 20:13
AEDT: November 13th 06:05 - November 13th 07:13

Users accessing the service via an integration may also have been affected.

However, we are pleased to advise that the issue has been resolved.

We regret any inconvenience caused.
Posted Nov 12, 2024 - 12:32 PST
Update
We are continuing to work on a fix for this issue.
Posted Nov 12, 2024 - 12:07 PST
Identified
We’ve run into some issues.

Turnitin and Turnitin UK are currently experiencing an unexpected service incident.

During this time, users may be unable to access the QuickMark manager or view QuickMarks.

Users accessing the service via an integration may also be affected.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Nov 12, 2024 - 12:03 PST
This incident affected: Turnitin (Turnitin Feedback Studio Grading Access) and Turnitin UK (Turnitin UK Feedback Studio Grading Access).