Unexpected service incident
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service incident, users of Turnitin Originality, Similarity and SimCheck as well as those accessing the service via an integration, may have experienced an unexpected service disruption.

We encountered the incident between the following times:

PDT September 14th 14:10 to September 14th 16:44
BST September 14th 23:10 to September 15th 01:44
AEST September 15th 08:10 to September 15th 10:44

Please accept our apologies if you were impacted.
Posted Sep 14, 2021 - 17:22 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 14, 2021 - 15:52 PDT
Investigating
Due to an unexpected service incident, users of Turnitin Originality, Similarity and SimCheck as well as those accessing the service via an integration, may experience an unexpected service disruption. Our engineers are actively investigating this incident. We apologize for the inconvenience.
Posted Sep 14, 2021 - 15:01 PDT
This incident affected: Americas (US environment) (Turnitin Logins, Paper Submissions, Report Processing Time, API).