Unexpected Service Incident
Incident Report for Turnitin
Resolved
Due to an unexpected service incident with one of our 3rd party providers, Turnitin Feedback Studio and integration users may have experienced a delay in report generation if Translated Matching has been enabled on the assignment.

We are pleased to advise that service has been restored.

The incident occurred between the following times:

PDT: October 20th 01:34 - October 20th 06:46
BST: October 20th 09:34- October 20th 14:46
AEDT: October 20th 19:34 - October 21st 00:46

We regret any inconvenience this may have caused if you were impacted by today’s incident.
Posted Oct 20, 2023 - 07:29 PDT
Identified
Due to an unexpected service incident with one of our 3rd party providers, Turnitin Feedback Studio and integration users may experience a delay in report generation if Translated Matching has been enabled on the assignment.

Whilst this incident is ongoing, if you are looking for immediate access to the Similarity Reports, temporarily disabling Translated Matching on the assignment will allow the Similarity Reports to generate.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Oct 20, 2023 - 04:50 PDT
This incident affected: Turnitin (Turnitin Report Processing Time) and Turnitin UK (Turnitin UK Report Processing Time).