Submissions & Similarity Reports not viewable
Incident Report for Turnitin
Resolved
We’ve fixed it!

Users of Turnitin and Turnitin UK, iThenticate as well as those accessing these services via an integration, may have been unable to view submissions and/or Similarity Reports, as well as experienced slowness when accessing the service. We are pleased to announce that this has now been resolved.

We encountered a degradation between the following times:

PST Dec 09 05:20 - Dec 09 13:30
GMT Dec 09 13:20 - Dec 09 21:30
AEDT Dec 10 00:20 - Dec 10 08:30

Please accept our apologies if you were impacted by this degradation.
Posted Dec 09, 2020 - 15:46 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 09, 2020 - 09:45 PST
Update
Turnitin, Turnitin UK and iThenticate are currently experiencing an unexpected service degradation. Users accessing these services via an integration may also be impacted. We are continuing to investigate this issue.

During this time, you may find that you are unable to view submissions and/or Similarity Reports, as well as experience slowness when accessing the service.

Apologies for any inconvenience this may cause. We invite you to track the progress of this disruption while we work to bring the service back to optimum health.
Posted Dec 09, 2020 - 08:14 PST
Update
We are continuing to investigate this issue.
Posted Dec 09, 2020 - 08:06 PST
Investigating
We’ve run into some issues.

Turnitin.com and Turnitinuk.com are currently experiencing an unexpected service degradation. Users accessing these services via an integration may also be impacted.

During this time, you may find that you are unable to view submissions and/or Similarity Reports.

We invite you to track the progress of this disruption while we work to bring the service back to optimum health.
Posted Dec 09, 2020 - 07:28 PST
This incident affected: iThenticate (iThenticate Report Processing Time), Turnitin (Turnitin Paper Submissions, Turnitin Feedback Studio Access, Turnitin Feedback Studio Grading Access), and Turnitin UK (Turnitin UK Paper Submissions, Turnitin UK Feedback Studio Grading Access).