Degraded Performance
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected third party intermittent service degradation, users of Turnitin, Turnitin UK, & iThenticate may be experiencing sporadic network issues while trying to use the service.

We are pleased to advise that the service has been restored.

We encountered a degradation between the following times:

PDT August 12th 10:10 – August 12th 11:06
BST August 12th 18:10 – August 12th 19:06
AEST August 13th 03:10 – August 13th 04:06

Please accept our apologies if you were impacted by today’s degradation
Posted Aug 12, 2021 - 12:06 PDT
Update
We have identified the issue, and we are currently working on implementing a solution.

We invite you to track the progress of this degradation while we work to bring the service back to optimum health.
Posted Aug 12, 2021 - 11:33 PDT
Identified
We’ve run into some issues.

Due to an unexpected third party intermittent service degradation, users of Turnitin, Turnitin UK, & iThenticate may be experiencing sporadic network issues while trying to use the service.

We invite you to track the progress of this degradation while we work to bring the service back to optimum health.
Posted Aug 12, 2021 - 11:03 PDT
This incident affected: Turnitin UK (Turnitinuk.com, Turnitin UK Logins, Turnitin UK Paper Submissions, Turnitin UK Report Processing Time, Turnitin UK Feedback Studio Access, Turnitin UK Feedback Studio Grading Access), Europe (EU environment) (Turnitin Logins, Paper Submissions, Report Processing Time, API), Asia Pacific (Asia Pacific environment) (Turnitin Logins, Paper Submissions, Report Processing Time, API), Turnitin (Turnitin.com, Turnitin Logins, Turnitin Paper Submissions, Turnitin Report Processing Time, Turnitin Feedback Studio Access, Turnitin Feedback Studio Grading Access), Americas (US environment) (Turnitin Logins, Paper Submissions, Report Processing Time, API), and iThenticate (iThenticate Website, iThenticate Report Processing Time, iThenticate API).