Turnitin Service Incident - 01 January
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service incident, you may have encountered an error when attempting to download Similarity Reports or Digital Receipt in Turnitin, Turnitin UK and iThenticate today. We are pleased to advise that service has been restored.

The incident occurred between the following times:
PST: 1st January 17:00 - 1st January 18:44
GMT: 2nd January 01:00 - 2nd January 02:44
AEDT: 2nd January 12:00 - 2nd January 13:44

We regret any inconvenience this may have caused if you were impacted by today’s incident.
Posted Jan 01, 2024 - 19:05 PST
Identified
We’ve run into some issues.

Turnitin, Turnitin UK and iThenticate are currently experiencing an unexpected service incident.

During this time, you may encounter an error when attempting to download Similarity Reports or Digital receipts.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Jan 01, 2024 - 18:11 PST
This incident affected: Turnitin (Turnitin.com), Turnitin UK (Turnitinuk.com), iThenticate (iThenticate Website), and Crossref Similarity Check ((v1) Similarity Reports Generation).