Similarity, Originality, SimCheck & Crossref Similarity Check - Service disruption
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service disruption, users of Turnitin Similarity, Originality, SimCheck & Crossref Similarity Check, may have been unable to log in or access Similarity Reports today. We are pleased to advise that service has been restored.

The incident occurred between the following times:

PDT September 24th 09:06 - September 24th 09:31
BST September 24th 17:06 - September 24th 17:31
AEST September 25th 02:06 - September 25th 02:31

Please accept our apologies if you were impacted by today’s incident.
Posted Sep 24, 2021 - 10:41 PDT
Identified
Turnitin Similarity, Originality and SimCheck are currently experiencing an unexpected service disruption. We also believe that Crossref Similarity Check may also be affected.

The issue has been identified and a fix is being implemented.
Posted Sep 24, 2021 - 09:53 PDT
Investigating
We’ve run into some issues.

Turnitin Similarity, Originality and SimCheck are currently experiencing an unexpected service disruption.

During this time, you may find that logging in to the website or via an integration returns an error. You may also find that you are also unable to access Similarity Reports.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Sep 24, 2021 - 09:24 PDT
This incident affected: Asia Pacific (Asia Pacific environment) (Turnitin Logins, Paper Submissions, Report Processing Time, API), Europe (EU environment) (Turnitin Logins, Paper Submissions, Report Processing Time, API), and Crossref Similarity Check ((v2) Website Logins, (v2) Paper Submissions Processing, (v2) Similarity Reports Generation).