Delayed Similarity Report Generation
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service degradation, you may have experienced slower than expected Similarity Report generation times in Turnitin and TurnitinUK. We are pleased to advise that service has been restored.

The incident occurred between the following times:

PDT: March 22nd 23:24 - March 23rd 04:35
GMT: March 23rd 06:24 - March 23rd 11:35
AEDT: March 23rd 17:24 - March 23rd 22:35

Please accept our apologies if you were impacted by today’s incident.
Posted Mar 23, 2022 - 04:35 PDT
Update
We are currently investigating an issue with Turnitin and TurnitinUK experiencing an unexpected service incident.

During this time, you may find that submissions take longer than expected to generate Similarity Reports.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Mar 23, 2022 - 03:34 PDT
Investigating
We’ve run into some issues.

Turnitin and TurnitinUK are currently experiencing an unexpected service incident.

During this time, you may find that submissions take longer than expected to generate Similarity Reports.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Mar 23, 2022 - 02:35 PDT
This incident affected: Turnitin UK (Turnitin UK Report Processing Time) and Turnitin (Turnitin Report Processing Time).