iThenticate Service Incident - 11 Oct 2023
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service incident, you may have been unable to access iThenticate V1 today. We are pleased to advise that the service has been restored.

The incident occurred between the following times:

October 10th 20:06 PDT - October 10th 20:50 PDT
October 11th 04:06 BST - October 11th 04:50 BST
October 11th 14:06 AEDT - October 11th 14:50 AEDT

We regret any inconvenience this may have caused if you were impacted by today’s incident.
Posted Oct 10, 2023 - 21:24 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 10, 2023 - 20:57 PDT
Identified
We’ve run into some issues.

iThenticate is currently experiencing an unexpected service incident.

During this time, you may encounter difficulties accessing iThenticate V1.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Oct 10, 2023 - 20:36 PDT
This incident affected: iThenticate (iThenticate Website) and Crossref Similarity Check ((v1) Website Logins).