Turnitin and Turnitin UK unavailable
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service outage affecting our CDN provider today, users of Turnitin and Turnitin UK may have been unable to access either service and were shown a 503 error when attempting to access the service or our main site. Users accessing these services via an integration may also have been affected.

We are pleased to advise that service has been restored.

We encountered a disruption between the following times:

PDT June 8th 02:55 - June 8th 05:41
BST June 8th 10:55 - June 8th 13:41
AEST June 8th 19:55 - June 8th 22:41

Please accept our apologies if you were impacted by today’s disruption.
Posted Jun 08, 2021 - 06:15 PDT
Monitoring
We have implemented a solution to mitigate the issue our CDN provider is experiencing.

Users of Turnitin.com and Turnitinuk.com should now be able to access these services again. Users accessing these services via the Blackboard Basic integration should no longer be encountering issues.

The main websites for Turnitin.com and Turnitinuk.com will remain unavailable until the underlying issue is resolved.
Posted Jun 08, 2021 - 04:00 PDT
Identified
Turnitin.com and Turnitinuk.com are currently experiencing an unexpected service disruption.

During this time, you may find that users are unable to access either service and are shown a 503 error when attempting to access the login page or main site. Users accessing these services via the Blackboard Basic integration may be impacted too.

We believe this disruption is due to a service outage our CDN provider is experiencing.

We invite you to track the progress of this disruption while we work to bring the service back to optimum health.
Posted Jun 08, 2021 - 03:21 PDT
Investigating
We’ve run into some issues.

Turnitin.com and Turnitinuk.com are currently experiencing an unexpected service disruption.

During this time, you may find that users are unable to access either service and are shown a 503 error when attempting to access the login page or main site.

We invite you to track the progress of this disruption while we work to bring the service back to optimum health.
Posted Jun 08, 2021 - 03:09 PDT
This incident affected: Turnitin UK (Turnitinuk.com, Turnitin UK Logins) and Turnitin (Turnitin.com, Turnitin Logins).