Slowness in generating a Similarity Report
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service incident, you may have experienced slower Similarity Report generation times in Turnitin Feedback Studio and iThenticate. We are pleased to advise the service has been restored.

The incident occurred between the following times:

PST: November 28th 21:48 - November 29th 02:10
GMT: November 29th 05:48 - November 29th 10:10
AEDT: November 29th 16:48 - November 29th 21:10

We regret any inconvenience this may have caused if you were impacted by today’s incident.
Posted Nov 29, 2022 - 02:17 PST
Update
We are continuing to monitor for any further issues.
Posted Nov 29, 2022 - 01:53 PST
Update
We are continuing to monitor for any further issues.
Posted Nov 29, 2022 - 01:23 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 29, 2022 - 00:29 PST
Identified
Due to an unexpected service incident, you may be experiencing slower Similarity Report generation times in Turnitin.com, TurnitinUK.com, and iThenticate.

We have identified the issue, and we are working to clear the backlog. Please accept our apologies for any inconvenience this may cause.
Posted Nov 29, 2022 - 00:26 PST
This incident affected: Turnitin (Turnitin.com, Turnitin Report Processing Time), iThenticate (iThenticate Website, iThenticate Report Processing Time, iThenticate API), and Turnitin UK (Turnitinuk.com, Turnitin UK Report Processing Time).