Delayed Similarity Report generation
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected backlog, you may have experienced a delay in Similarity Report generation time in Turnitin, Turnitin UK, and those accessing Turnitin via an integration today. We are pleased to advise that service has been restored.

The incident occurred between the following times:

PST: February 11th 15:06 - February 11th 18:44
GMT: February 11th 23:06 - February 12th 02:44
AEDT: February 12th 10:06 - February 12th 13:44

Please accept our apologies if you were impacted by today’s incident.
Posted Feb 11, 2022 - 18:54 PST
Monitoring
We’ve run into some issues.

Users of Turnitin, Turnitin UK, and those accessing Turnitin via an integration may experience a Similarity Report generation delay, and may find that the report processing time to be slower than usual.

We are actively working to process a backlog of submissions affected by this issue.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Feb 11, 2022 - 18:15 PST
This incident affected: iThenticate (iThenticate Report Processing Time), Crossref Similarity Check ((v1) Similarity Reports Generation, (v2) Similarity Reports Generation), Europe (EU environment) (Report Processing Time), Americas (US environment) (Report Processing Time), Asia Pacific (Asia Pacific environment) (Report Processing Time), Turnitin UK (Turnitin UK Report Processing Time), and Turnitin (Turnitin Report Processing Time).