Due to an unexpected service incident, users of Turnitin, Turnitin UK, iThenticate V1, iThenticate V2 and Crossref Similarity Check might have experienced issues accessing the service when logging in via Shibboleth SSO today. We are pleased to advise that service has been restored.
The incident occurred between the following times:
PST: Tuesday, 3rd March 07:00 - Tuesday, 3rd March 09:48 GMT: Tuesday, 3rd March 15:00 - Tuesday, 3rd March 17:48 AEDT: Wednesday, 4th March 02:00 - Wednesday, 4th March 04:48
We regret any inconvenience this may have caused if you were impacted by today’s incident.
Posted Mar 03, 2026 - 10:11 PST
Investigating
We’ve run into some issues.
Turnitin, Turnitin UK, iThenticate V1, iThenticate V2 and Crossref Similarity Check are currently experiencing an unexpected service incident.
During this time, users accessing the service via Shibboleth SSO may be unable to log in. Users accessing the service through other login methods are not affected.
We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Mar 03, 2026 - 09:43 PST
This incident affected: iThenticate (iThenticate Website), Crossref Similarity Check ((v1) Website Logins, (v2) Website Logins), iThenticate 2.0 (Native website login), Turnitin (Turnitin Logins), and Turnitin UK (Turnitin UK Logins).