Turnitin Service Incident - 2nd June 2025

Incident Report for Turnitin

Resolved

We’ve fixed it!

Due to an unexpected service incident, users of Turnitin, Turnitin UK, iThenticate V1, Crossref and users who access these services via an integration might have experienced difficulties accessing the service. We’re pleased to confirm that the issue has now been resolved.

The incident occurred between the following times:

PDT: June 2nd, 17:00 - June 2nd, 18:21
BST: June 3rd, 01:00 - June 3rd, 02:21
AEST: June 3rd, 10:00 - June 3rd, 11:21

We regret any inconvenience this may have caused if you were impacted by today’s incident.
Posted Jun 02, 2025 - 18:31 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 02, 2025 - 17:59 PDT

Investigating

We’ve run into some issues.

Turnitin is currently experiencing an unexpected service incident.

During this time, users of Turnitin, Turnitin UK, iThenticate V1, Crossref and users who access these services via an integration may experience difficulties accessing the service.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Jun 02, 2025 - 17:47 PDT
This incident affected: iThenticate (iThenticate Website), Crossref Similarity Check ((v1) Website Logins), Turnitin (Turnitin Logins), and Turnitin UK (Turnitin UK Logins).