Slowness while submitting
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service degradation, Turnitin, TurnitinUK and integrations users may have experienced slowness when submitting using the service. We are pleased to advise that service has been restored.

We encountered a degradation between the following times:

PST Nov 05 08:17 - Nov 05 10:13
BST Nov 05 17:17 - Nov 05 19:13
AEDT Nov 06 03:17 - Nov 06 05:13

Please accept our apologies if you were impacted by today’s disruption.
Posted Nov 05, 2020 - 11:55 PST
Investigating
We’ve run into some issues.

Turnitin.com & Turnitinuk.com are currently experiencing an unexpected service disruption.

During this time, you may experience slowness when submitting to these services.

We invite you to track the progress of this disruption while we work to bring the service back to optimum health.
Posted Nov 05, 2020 - 09:15 PST
This incident affected: Turnitin (Turnitin Paper Submissions) and Turnitin UK (Turnitin UK Paper Submissions).