Slow Similarity Report generation
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service degradation, users accessing Turnitin, Turnitin UK and iThenticate, may have experienced slowness in file uploading and/or delay in report generation time for your Similarity Reports.

We are pleased to advise that service has been restored.


The service degradation occurred between the following times:

PST Nov 28th 18:30 - Nov 29th 01:20

GMT Nov 29th 02:30 - Nov 29th 09:20

AEDT Nov 29th 13:30 - Nov 29th 20:20


Please accept our apologies if you were impacted by today’s incident.
Posted Nov 29, 2021 - 01:54 PST
Monitoring
A fix has been implemented and we are working to process the backlog created by this incident. We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Nov 29, 2021 - 00:14 PST
Investigating
We’ve run into some issues.

Turnitin, Turnitin UK and iThenticate are currently experiencing unexpected service degradation.
Users accessing these services via an integration may also be affected.

During this time, you may experience slowness in file uploading and/or a delay in report generation time for your Similarity Reports.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Nov 28, 2021 - 22:56 PST
This incident affected: iThenticate (iThenticate Report Processing Time), Turnitin (Turnitin Paper Submissions, Turnitin Report Processing Time), and Turnitin UK (Turnitin UK Paper Submissions, Turnitin UK Report Processing Time).