Report Generation Issue
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service incident, users of Turnitin, Turnitin UK, SimCheck, Similarity, and Originality accessing these services via the Canvas Plagiarism Framework integration may have been unable to receive Similarity Reports today.

Users of Turnitin & Turnitin UK may have also experienced delays in Similarity Report generation. We are pleased to advise that service has now been restored for iThenticate and Crossref Similarity Check as well.

We are continuing to work through the backlog of submissions caused by this incident affecting iThenticate and Crossref Similarity Check. However, new submissions should no longer be affected.

The incident occurred between the following times:

PDT: May 9th 03:24 - May 9th 09:40
BST: May 9th 11:24 - May 9th 17:40
AEST: May 9th 20:24 - May 10th 02:40

Please accept our apologies if you were impacted by today’s incident.
Posted May 09, 2022 - 10:31 PDT
Update
The earlier incident affecting Similarity Report generation for users of Turnitin and Turnitin UK, SimCheck, Similarity, and Originality accessing these services via the Canvas Plagiarism Framework integration has now been resolved. The issue causing delayed report generation for Turnitin and Turnitin UK has also been resolved.

Users of iThenticate and Crossref Similarity Check may still experience delays in report generation while we work through the backlog caused by this incident.

We apologize for any inconvenience this may cause.
Posted May 09, 2022 - 08:40 PDT
Monitoring
A fix has been implemented and we are monitoring the results.

The delays in report generation will persist while we work through a backlog caused by the incident.

Users of Turnitin, Turnitin UK, SimCheck, Similarity, and Originality accessing these services via the Canvas Plagiarism Framework integration may be unable to receive Similarity Reports.

Users of Turnitin, Turnitin UK, iThenticate and Crossref Similarity Check may also experience delays in Similarity Report generation.
Posted May 09, 2022 - 06:06 PDT
Identified
We’ve run into some issues.

Turnitin is currently experiencing an unexpected service incident.

Users of Turnitin, Turnitin UK, SimCheck, Similarity, and Originality accessing these services via the Canvas Plagiarism Framework integration may be unable to receive Similarity Reports.

Users of Turnitin, Turnitin UK, iThenticate and Crossref Similarity Check may also experience delays in Similarity Report generation.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted May 09, 2022 - 04:16 PDT
This incident affected: iThenticate (iThenticate Report Processing Time, iThenticate API), Crossref Similarity Check ((v1) Similarity Reports Generation), Americas (US environment) (Report Processing Time, API), Europe (EU environment) (Report Processing Time, API), Asia Pacific (Asia Pacific environment) (Report Processing Time, API), Turnitin (Turnitin Report Processing Time), and Turnitin UK (Turnitin UK Report Processing Time).