Unexpected Service Degradation
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service degradation, users of Turnitin, Turnitin UK, Turnitin Similarity, SimCheck, Originality, Crossref Similarity Check, iThenticate as well as users accessing Turnitin via an integration may have experienced delayed report-generation times for your Similarity Reports. We are pleased to advise that the service has been restored.

The incident occurred between the following times:

PST: February 17th 12:10 - February 17th 15:10
GMT: February 17th 20:10 - February 17th 23:10
AEDT: February 18th 07:10 - February 18th 10:10

Please accept our apologies if you were impacted by today’s incident.
Posted Feb 17, 2022 - 15:28 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 17, 2022 - 15:09 PST
Identified
We’ve run into some issues.

Users using Turnitin, Turnitin UK, Turnitin Similarity, SimCheck, Originality, Crossref Similarity Check, iThenticate as well as users accessing Turnitin via an integration may experience a Similarity Report generation delay, and may find that the report processing time to be slower than usual.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Feb 17, 2022 - 15:04 PST
This incident affected: iThenticate (iThenticate Report Processing Time), Draft Coach (Draft Coach Report Processing Times), Crossref Similarity Check ((v1) Similarity Reports Generation, (v2) Similarity Reports Generation), Europe (EU environment) (Report Processing Time), Americas (US environment) (Report Processing Time), Asia Pacific (Asia Pacific environment) (Report Processing Time), Turnitin UK (Turnitin UK Report Processing Time), and Turnitin (Turnitin Report Processing Time).