Report Generation issue
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service incident, users of Turnitin, TurnitinUK, iThenticate, Turnitin Originality, Turnitin Similarity, SimCheck and Crossref Similarity Check, as well as those accessing the service via an integration, may have experienced slower Similarity Report generation times.

We are pleased to advise that service has been restored and the backlog of submissions from the previous incident has also been cleared.

The incident occurred between the following times:

PDT: May 31st 16:30 - May 31st 22:30
BST: June 1st 00:30 - June 1st 06:30
AEST: June 1st 09:30 - June 1st 15:30

Please accept our apologies if you were impacted by today’s incident.
Posted May 31, 2022 - 23:21 PDT
Monitoring
A fix has been implemented and we are monitoring the results. We are also continuing to work through the backlog of submissions that have been affected by this incident.
Posted May 31, 2022 - 18:49 PDT
Investigating
We’ve run into some issues.

Users of Turnitin and TurnitinUK, iThenticate, as well as Turnitin Originality, Turnitin Similarity, SimCheck and Crossref Similarity Check are currently experiencing an unexpected service incident.

Users also accessing these services via an integration may also be affected. During this time, users may be experiencing slower than normal report generation times.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted May 31, 2022 - 18:08 PDT
This incident affected: iThenticate (iThenticate Report Processing Time), Draft Coach (Draft Coach Report Processing Times), Crossref Similarity Check ((v1) Similarity Reports Generation, (v2) Similarity Reports Generation), Europe (EU environment) (Report Processing Time), Americas (US environment) (Report Processing Time), Asia Pacific (Asia Pacific environment) (Report Processing Time), Turnitin UK (Turnitin UK Report Processing Time), and Turnitin (Turnitin Report Processing Time).