Unable to submit to Turnitin
Incident Report for Turnitin
Resolved
We are glad to announce that the issue has been resolved. The service is getting back to normal and paper processing times will be longer than usual.
Posted Nov 13, 2019 - 10:41 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 13, 2019 - 10:11 PST
Update
We are continuing to investigate this issue.
Posted Nov 13, 2019 - 09:41 PST
Update
Turnitin and Turnitin UK are currently down and users are unable to log in or make submissions. We are working on this issue as our top priority and are performing emergency maintenance. Apologies for any inconvenience this may be causing.
Posted Nov 13, 2019 - 09:35 PST
Update
We are continuing to investigate this issue.
Posted Nov 13, 2019 - 09:23 PST
Update
We are continuing to investigate this issue.
Posted Nov 13, 2019 - 09:22 PST
Update
Users of the Turnitin and Turnitin UK services may be unable to make submissions or experience slowness when uploading submissions. We are working on this issue as our top priority. Apologies for any inconvenience this may be causing.
Posted Nov 13, 2019 - 09:05 PST
Investigating
We’ve run into some issues.

Turnitin and Turnitin UK are currently experiencing an unexpected service disruption.

During this time, you may find that you are unable to make a submission or that uploading submissions takes longer than expected.

We invite you to track the progress of this disruption while we work to bring service back to optimum health.
Posted Nov 13, 2019 - 08:33 PST
This incident affected: Turnitin (Turnitin.com, Turnitin Logins, Turnitin Paper Submissions, Turnitin Report Processing Time, Turnitin Feedback Studio Access, Turnitin Feedback Studio Grading Access) and Turnitin UK (Turnitinuk.com, Turnitin UK Paper Submissions, Turnitin UK Report Processing Time).