Turnitin Status Notification
Incident Report for Turnitin
Resolved
The Turnitin website is currently experiencing intermittent availability.

The Turnitin service is fully operational and can be accessed through https://turnitin.com/login_page.asp, if turnitin.com is unavailable.
Posted Feb 04, 2020 - 07:27 PST
Investigating
We’ve run into some issues.

The Turnitin website is currently experiencing an unexpected service disruption.

During this time, you may find that you are unable to access turnitin.com. To login to Turnitin please go to https://turnitin.com/login_page.asp

We invite you to track the progress of this disruption while we work to bring service back to optimum health.
Posted Feb 04, 2020 - 06:50 PST
This incident affected: Turnitin (Turnitin.com).