Delayed Similarity Report generation
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service incident, users may have experienced slower than usual Similarity Report generation when using Turnitin, TurnitinUK, iThenticate and CrossRef Similarity Check. We are pleased to advise that service has been restored.

The incident occurred between the following times:

PST: December 13th 13:30 - December 14th 02:30
GMT: December 13th 21:30 - December 14th 10:30
AEDT: December 14th 08:30 - December 14th 21:30

Please accept our apologies if you were impacted by today’s incident.
Posted Dec 14, 2021 - 03:04 PST
Update
We are continuing to investigate the issue.

Customers generating Similarity Reports via CrossRef Similarity Check may also be affected.
Posted Dec 14, 2021 - 02:18 PST
Investigating
We’ve run into some issues.

Turnitin, TurnitinUK and iThenticate are currently experiencing an unexpected service incident.

During this time, you may find that Similarity Report generation is taking longer than expected.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Dec 14, 2021 - 01:45 PST
This incident affected: iThenticate (iThenticate Report Processing Time), Crossref Similarity Check ((v1) Similarity Reports Generation), Turnitin UK (Turnitin UK Report Processing Time), and Turnitin (Turnitin Report Processing Time).