Downloading Similarity Report
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service incident, you may have experienced slowness in downloading Similarity Reports across all products today. We are pleased to advise that service has been restored.

The incident occurred between the following times:

PDT: September 20th 17:00 - September 20th 20:14
BST: September 21st 01:00 - September 21st 04:14
AEST: September 21st 10:00 - September 21st 13:14

We regret any inconvenience this may have caused if you were impacted by today’s incident.
Posted Sep 20, 2022 - 20:34 PDT
Investigating
We’ve run into some issues.

Turnitin, Turnitin UK, iThenticate, Similarity, SimCheck, Originality, Draft Coach and Crossref Similarity Check are currently experiencing an unexpected service incident. Users accessing these services via an integration may also be affected.

During this time, you may experience slowness in downloading Similarity Reports.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Sep 20, 2022 - 20:16 PDT
This incident affected: iThenticate (iThenticate Report Processing Time), Crossref Similarity Check ((v1) Similarity Reports Generation, (v2) Paper Submissions Processing), Draft Coach (Draft Coach Report Processing Times), Europe (EU environment) (Report Processing Time), Americas (US environment) (Report Processing Time), Asia Pacific (Asia Pacific environment) (Report Processing Time), Turnitin (Turnitin Report Processing Time), and Turnitin UK (Turnitin UK Report Processing Time).