Turnitin and iThenticate Status Notification
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected outage, you may have been unable to upload papers and have reports generated in Turnitin, TurnitinUk, iThenticate, Similarity and SimCheck today. We are pleased to advise that service has been restored.

We encountered a disruption between the following times:

PDT Sep 18 14:00 - 17:00
BST Sep 18 22:00 - 01:00
AEST Sep 19 07:00 - 10:00

We sincerely apologize for the inconvenience.
Posted Sep 18, 2020 - 18:49 PDT
Monitoring
We’re pleased to inform you that the paper upload process has been restored to all platform as well as the report processing time. We are currently working on processing the submissions we have received. We apologize for the delay and any inconvenience this issue is causing, your patience is greatly appreciated. For updates, please continue to monitor our status page at https://turnitin.statuspage.io/.
Posted Sep 18, 2020 - 17:49 PDT
Update
We’re pleased to inform you that the paper upload process has been restored to all platforms. We are now working on restoring the report generation. We apologize for the delay and any inconvenience this issue is causing, your patience is greatly appreciated. For updates, please continue to monitor our status page at https://turnitin.statuspage.io/.
Posted Sep 18, 2020 - 16:15 PDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 18, 2020 - 15:41 PDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 18, 2020 - 15:38 PDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 18, 2020 - 15:37 PDT
Identified
We are pleased to inform you that papers upload process has been restored to Turnitin.com and TurnitinUK.com. We are currently working on implementing a solution to generate reports. Thank you for your patience. For updates, please visit and subscribe to https://turnitin.statuspage.io/
Posted Sep 18, 2020 - 15:26 PDT
Investigating
We are currently experiencing an issue with Turnitin and iThenticate. Our engineers are actively investigating the incident. We apologize for the inconvenience and thank you for your patience. For updates, please visit https://turnitin.statuspage.io/
Posted Sep 18, 2020 - 14:35 PDT
This incident affected: Europe (EU environment) (Turnitin Logins, Paper Submissions, Report Processing Time, API), Americas (US environment) (Turnitin Logins, Paper Submissions, Report Processing Time, API), iThenticate (iThenticate Website, iThenticate Report Processing Time, iThenticate API), Turnitin (Turnitin.com, Turnitin Logins, Turnitin Paper Submissions, Turnitin Report Processing Time, Turnitin Feedback Studio Access, Turnitin Feedback Studio Grading Access), Turnitin UK (Turnitinuk.com, Turnitin UK Logins, Turnitin UK Paper Submissions, Turnitin UK Report Processing Time, Turnitin UK Feedback Studio Access, Turnitin UK Feedback Studio Grading Access), and Asia Pacific (Asia Pacific environment) (Turnitin Logins, Paper Submissions, Report Processing Time, API).