Unexpected Service Degradation
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service degradation, users may have experienced a delay while uploading a submission and/or also may have experienced a delay with submissions generating a Similarity Report in Turnitin, Turnitin UK, iThenticate, SimCheck, Similarity, Originality and Crossref Similarity Check. We are pleased to advise that service has been restored.

The incident occurred between the following times:

PST Nov 19th 12:53 - Nov 19th 15:04
GMT Nov 19th 20:53 - Nov 19th 23:04
AEDT Nov 20th 07:53 - Nov 20th 10:04

Please accept our apologies if you were impacted by today’s incident.
Posted Nov 19, 2021 - 15:45 PST
Investigating
Users of Turnitin, Turnitin UK, iThenticate, SimCheck, Similarity, Originality and Crossref Similarity Check are currently experiencing an unexpected service degradation.

During this time, users may experience a delay while uploading a submission and/or may also experience delayed report-generation times for Similarity Reports.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Nov 19, 2021 - 14:28 PST
This incident affected: iThenticate (iThenticate Report Processing Time), Americas (US environment) (Paper Submissions, Report Processing Time), Turnitin (Turnitin Paper Submissions, Turnitin Report Processing Time), and Turnitin UK (Turnitin UK Paper Submissions, Turnitin UK Report Processing Time).