Turnitin Status Notification
Incident Report for Turnitin
Resolved
We’ve fixed it!

As a result of an expired authority within the certificate chain provided by our certificate authority, some customers may have experienced a service disruption. During the below time window, you may have been unable to load assignments or submit papers in Turnitin and Turnitin UK via some integrations. We are pleased to advise that service has been restored.

We encountered a disruption between the following times:
PDT 03:48am - 06:18am
BST 11:48am - 2:18pm
AEST 20:48pm - 23:18pm

Please accept our apologies if you were impacted by today’s disruption.
Posted May 30, 2020 - 07:24 PDT
Update
Our engineers are currently implementing a fix for these issues. We are currently monitoring. Please accept our apologies.
Posted May 30, 2020 - 05:35 PDT
Identified
We’ve run into some issues.

Blackboard Direct is currently experiencing an unexpected service disruption.

During this time, you may find that issues loading Turnitin assignments and submitting papers.

We invite you to track the progress of this disruption while we work to bring the service back to optimum health.
Posted May 30, 2020 - 05:15 PDT