Unexpected Service Incident
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service incident, you may have experienced intermittent access issues and slowness when opening Similarity Reports, as well as received errors when attempting to grade, or add feedback in Turnitin and Turnitin UK today. Users accessing these services via an integration may also have been affected. We are pleased to advise that service has been restored.

The incident occurred between the following times:

PST: January 16th 02:19 - January 16th 07:31
GMT: January 16th 10:19 - January 16th 15:31
AEDT: January 16th 21:19 - January 17th 02:31

We regret any inconvenience this may have caused if you were impacted by today’s incident.
Posted Jan 16, 2023 - 07:53 PST
Investigating
We’ve run into some issues.

Due to an unexpected service incident, users of Turnitin and Turnitin UK may be experiencing intermittent access issues and slowness when opening Similarity Reports, as well as receiving errors when attempting to grade or add feedback.

Users accessing these services via an integration may also be affected.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Jan 16, 2023 - 02:59 PST
This incident affected: Turnitin UK (Turnitin UK Feedback Studio Access, Turnitin UK Feedback Studio Grading Access) and Turnitin (Turnitin Feedback Studio Access, Turnitin Feedback Studio Grading Access).