Unexpected Service Disruption
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service disruption, users accessing Turnitin via the website directly, may have been unable to log in, make or access submissions, or view Similarity Reports. Users accessing the service via an integration may have also been affected and been unable to submit, view submissions or create assignments today.

We are pleased to advise that service has been restored.

The incident occurred between the following times:

PDT September 28th 09:54 - September 28th 10:36
BST September 28th 17:54 - September 28th 18:36
AEST September 29th 02:54 - September 29th 03:36

Please accept our apologies if you were impacted by today’s incident.
Posted Sep 28, 2021 - 11:26 PDT
Monitoring
A fix has been implemented and we are monitoring the results.

Users accessing the service via the website should now be able to log in, access submissions and view Similarity Reports.

However, users accessing the service via an integration, may be unable to submit, view submissions, or create assignments.

We are continuing to investigate and are working to bring the service back to optimum health.
Posted Sep 28, 2021 - 10:44 PDT
Investigating
We’ve run into some issues.

Turnitin is currently experiencing an unexpected service disruption.

During this time, users accessing the service via the website directly may be unable to log in, access submissions, or view Similarity Reports. Users accessing the service via an integration may also be affected.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Sep 28, 2021 - 10:35 PDT
This incident affected: Turnitin (Turnitin Logins, Turnitin Paper Submissions, Turnitin Feedback Studio Access, Turnitin Feedback Studio Grading Access).