Unexpected Service Incident
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service incident, you may have encountered errors accessing Turnitin, TurnitinUK, and iThenticate. You may have also experienced delays in Similarity Report generation times.

We are pleased to advise that service has been restored.

The incident occurred between the following times:

PDT: May 10th 02:22 - May 10th 06:05
BST: May 10th 10:22 - May 10th 14:05
AEST: May 10th 19:22 - May 10th 23:05

Please accept our apologies if you were impacted by today’s incident.
Posted May 10, 2022 - 06:38 PDT
Monitoring
A fix has been implemented, and we are monitoring the results.

The delays in processing submissions, and report generation, will persist while we work through a backlog caused by the incident.

This will impact users of Turnitin, Turnitin UK, iThenticate, and users accessing these services via an integration.
Posted May 10, 2022 - 06:07 PDT
Update
We are continuing to investigate the issue.

Turnitin, TurnitinUK and iThenticate are experiencing an unexpected service incident. This may also impact users accessing these services via an integration.

During this time, you may find that users are experiencing slower than usual file uploads and delayed Similarity Report generation times.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted May 10, 2022 - 04:07 PDT
Investigating
We’ve run into some issues.

Turnitin, TurnitinUK and iThenticate are currently experiencing an unexpected service incident. This may also impact users accessing these services via an integration.

During this time, you may find that users accessing these services are unable to access Similarity Reports, or are experiencing delayed Similarity Report generation times.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted May 10, 2022 - 03:04 PDT
This incident affected: Crossref Similarity Check ((v1) Website Logins, (v1) Similarity Reports Generation), iThenticate (iThenticate Website, iThenticate Report Processing Time), Turnitin (Turnitin Paper Submissions, Turnitin Report Processing Time, Turnitin Feedback Studio Access, Turnitin Feedback Studio Grading Access), and Turnitin UK (Turnitin UK Paper Submissions, Turnitin UK Report Processing Time, Turnitin UK Feedback Studio Access, Turnitin UK Feedback Studio Grading Access).