Delayed Similarity Report Generation
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service incident, you may have experienced slow generation of reports in Turnitin, TurnitinUK, iThenticate and Crossref Similarity Check today. We are pleased to advise that service has been restored.

The incident occurred between the following times:

PDT: April 4th 06:42 - April 4th 07:14
BST: April 4th 14:42 - April 4th 15:14
AEST: April 4th 11:42 - April 5th 00:14

Please accept our apologies if you were impacted by today’s incident.
Posted Apr 04, 2022 - 07:22 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 04, 2022 - 07:11 PDT
Investigating
We’ve run into some issues.

Turnitin, TurnitinUK, iThenticate, Crossref Similarity Check, and users accessing these services via an integration, are currently experiencing an unexpected service incident.

During this time, you may find that submissions take longer than expected to generate Similarity Reports.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Apr 04, 2022 - 06:45 PDT
This incident affected: iThenticate (iThenticate Report Processing Time), Crossref Similarity Check ((v1) Similarity Reports Generation), Turnitin UK (Turnitin UK Report Processing Time), and Turnitin (Turnitin Report Processing Time).