iThenticate Service Incident - 10th October 2023
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected incident, you may have experienced slowness logging in and using iThenticate V1 today. We are pleased to advise that service has been restored.

The incident occurred between the following times:

October 10th 02:00 PDT - October 10th 05:27 PDT
October 10th 10:00 BST - October 10th 13:27 BST
October 10th 20:00 AEDT - October 10th 23:27 AEDT

We regret any inconvenience this may have caused if you were impacted by today’s incident.
Posted Oct 10, 2023 - 05:43 PDT
Investigating
We’ve run into some issues.

iThenticate V1 is currently experiencing an unexpected service incident.

During this time, you may find that slowness logging in and using the service.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Oct 10, 2023 - 03:32 PDT
This incident affected: iThenticate (iThenticate Website, iThenticate API).