Turnitin service degradation
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to unexpected service degradation, users of Turnitin, Turnitin UK, as well as those accessing the service via an integration may have been unable to access the service. We are pleased to advise that the service has been restored.

We encountered a disruption between the following times:

PDT September 2nd 14:36 to September 2nd 20:00
BST September 2nd 22:23 to September 3rd 04:00
AEST September 3rd 07:23 to September 3rd 13:00

Please accept our apologies if you were impacted by this disruption.
Posted Sep 02, 2021 - 19:24 PDT
Update
We are continuing to monitor for any further issues.
Posted Sep 02, 2021 - 19:06 PDT
Monitoring
A fix has been implemented and we are monitoring the result.
Posted Sep 02, 2021 - 18:51 PDT
Update
We are continuing to investigate this issue.
Posted Sep 02, 2021 - 17:47 PDT
Investigating
We’ve run into some issues.

Users of Turnitin, Turnitin UK, as well as those accessing the service via an integration, may experience an unexpected service disruption.

We invite you to track the progress of this disruption while we work to bring the service back to optimum health.
Posted Sep 02, 2021 - 17:40 PDT
This incident affected: Turnitin (Turnitin.com, Turnitin Logins, Turnitin Paper Submissions, Turnitin Report Processing Time, Turnitin Feedback Studio Access, Turnitin Feedback Studio Grading Access) and Turnitin UK (Turnitinuk.com, Turnitin UK Logins, Turnitin UK Paper Submissions, Turnitin UK Report Processing Time, Turnitin UK Feedback Studio Access, Turnitin UK Feedback Studio Grading Access).