Slow Similarity Report generation & Similarity Reports not viewable (Canada Only)
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service degradation, users of Turnitin.com, as well as those accessing the service via an integration in Canada only, may have been unable to view Similarity Reports, and experienced slow report generation when accessing the service. We are pleased to announce that this has now been resolved.

We encountered a degradation between the following times:

PST Feb 16 08:34 - Feb 16 10:20
GMT Feb 16 16:34 - Feb 16 18:20
AEDT Feb 17 03:34 - Feb 17 05:20

Please accept our apologies if you were impacted by today’s disruption.
Posted Feb 16, 2021 - 10:56 PST
Investigating
We’ve run into some issues.

Turnitin.com is currently experiencing an unexpected service degradation. Users accessing the service via an integration may also be impacted.

During this time, users of the service in Canada only may find that they are unable to view Similarity Reports and experience slow report generation.

We invite you to track the progress of this disruption while we work to bring the service back to optimum health.
Posted Feb 16, 2021 - 10:27 PST
This incident affected: Turnitin (Turnitin Report Processing Time).