Turnitin.com degradation issue
Incident Report for Turnitin
Resolved
We are pleased to advise that the service degradation experienced has now been resolved and submissions are processing within usual timeframes. The disruption occurred at the times below:


PDT April 20th, 09:00 - 10:45

BST April 20th, 17:00 - 18:45

AEST April 21st, 02:00 - 03:45
Posted Apr 20, 2020 - 11:07 PDT
Investigating
We’re currently experiencing intermittent service degradation resulting in slow logins to Turnitin.com. Our engineers are currently working on this issue to restore normal service. For further updates, we invite you to track the progress here.
Posted Apr 20, 2020 - 10:23 PDT
This incident affected: Turnitin (Turnitin.com, Turnitin Logins).