Logging in and Delayed Similarity Report Generation
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to an unexpected service incident, users of Turnitin and TurnitinUK, iThenticate, Draft Coach, Turnitin Originality, Turnitin Similarity, SimCheck and Crossref Similarity Check, may have experienced issues logging in and slower than usual Similarity Report generation speeds. Users accessing these services via an integration may also have been affected.

However, we are pleased to advise that the service has now been restored.

The incident occurred between the following times:

PDT August 5th 01:15 - August 5th 03:05
BST: August 5th 09:15 - August 5th 11:05
AEST: August 5th 18:15 - August 5th 20:05

Please accept our apologies if you were impacted by today’s incident.
Posted Aug 05, 2022 - 04:19 PDT
Monitoring
A fix has been implemented and we are monitoring the results. We are also continuing to work through the backlog of submissions that have been affected by this incident, so you may still see a delay in report generation. Apologies for any inconvenience caused.
Posted Aug 05, 2022 - 03:34 PDT
Update
We are continuing to investigate this issue.
Posted Aug 05, 2022 - 02:38 PDT
Update
We are continuing to investigate this issue.
Posted Aug 05, 2022 - 02:35 PDT
Update
We are continuing to investigate this issue.
Posted Aug 05, 2022 - 02:27 PDT
Investigating
We’ve run into some issues.

Users of Turnitin and TurnitinUK, iThenticate, as well as Draft Coach, Turnitin Originality, Turnitin Similarity, SimCheck and Crossref Similarity Check are currently experiencing an unexpected service incident.

Users also accessing these services via an integration may also be affected. During this time, users may be experiencing intermittent issues logging in and slower report generation times.

We invite you to track the progress of this incident while we work to bring the service back to optimum health: https://t.co/oVlXfKk45h
Posted Aug 05, 2022 - 02:19 PDT
This incident affected: Turnitin (Turnitin.com, Turnitin Logins, Turnitin Report Processing Time), Turnitin UK (Turnitinuk.com, Turnitin UK Logins, Turnitin UK Report Processing Time), Asia Pacific (Asia Pacific environment) (Turnitin Logins, Report Processing Time), Americas (US environment) (Turnitin Logins, Report Processing Time), Europe (EU environment) (Turnitin Logins, Report Processing Time), iThenticate (iThenticate Report Processing Time), Draft Coach (Draft Coach Report Processing Times), and Crossref Similarity Check ((v1) Similarity Reports Generation, (v2) Similarity Reports Generation).