Due to an unexpected service incident, you may have found that users accessing the service via an integration encounter an error message in Feedback Studio today. We are pleased to advise that service has been restored.
The incident occurred between the following times:
We regret any inconvenience this may have caused if you were impacted by today’s incident.
Posted Jan 27, 2026 - 10:33 PST
Investigating
We’ve run into some issues.
Turnitin Feedback Studio is currently experiencing an unexpected service incident.
During this time, you may find that users accessing the service via an integration encounter an error message.
We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Jan 27, 2026 - 09:34 PST
This incident affected: Turnitin (Turnitin Feedback Studio Access, Turnitin Feedback Studio Grading Access) and Turnitin UK (Turnitin UK Feedback Studio Access, Turnitin UK Feedback Studio Grading Access).