Users unable to access SimCheck & Similarity
Incident Report for Turnitin
Resolved
Users of SimCheck or Similarity may have been unable to login to these services. Users accessing these services via an integration may have been unable to make submissions and/or view reports. We are pleased to advise that service has been restored.

We encountered a disruption between the following times:

PDT 03:00 - 07:41
BST 11:00 - 15:41
AEST 20:00 - 00:41

Please accept our apologies if you were impacted by today’s disruption.
Posted May 14, 2020 - 08:08 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 14, 2020 - 07:12 PDT
Update
We are continuing to investigate this issue.
Posted May 14, 2020 - 05:46 PDT
Investigating
We’ve run into some issues.

SimCheck & Similarity are currently experiencing an unexpected service disruption.

During this time, you may find that you are intermittently unable to login to these services. Users accessing these services via an integration may also be affected.

We invite you to track the progress of this disruption while we work to bring service back to optimum health.
Posted May 14, 2020 - 05:16 PDT
This incident affected: Americas (US environment) (Turnitin Logins, Paper Submissions, Report Processing Time, API).