Turnitin Service Incident - 14th April 2025

Incident Report for Turnitin

Resolved

We’ve fixed it!

Due to an unexpected service incident, users of Turnitin, Turnitin UK, Draft Coach, iThenticate, Crossref, and iThenticate V2 — including those accessing these services via integrations — may have experienced delays in Similarity Report generation or difficulty accessing the service. We are pleased to advise that service has been restored.

The incident occurred between the following times:

PDT: April 13th, 18:40 - April 13th, 21:45
BST: April 14th, 02:40 - April 14th, 05:45
AEST: April 14th, 11:40 - April 14th, 14:45

We regret any inconvenience this may have caused if you were impacted by today’s incident.
Posted Apr 13, 2025 - 21:50 PDT

Identified

We’ve run into some issues.

Turnitin, Turnitin UK, Draft Coach, iThenticate, Crossref, and iThenticate V2 are currently experiencing an unexpected service interruption. Users accessing these services through integrations may also be impacted.

During this time, you may notice delays in Similarity Report generation or issues accessing the service.

We appreciate your patience and invite you to track the progress of this incident as we work to restore full functionality.
Posted Apr 13, 2025 - 21:00 PDT
This incident affected: iThenticate (iThenticate Report Processing Time), Crossref Similarity Check ((v1) Similarity Reports Generation, (v2) Similarity Reports Generation), Draft Coach (Draft Coach Report Processing Times), iThenticate 2.0 (iThenticate Report Processing Time), Americas (US environment) (Report Processing Time), Turnitin (Turnitin Report Processing Time), and Turnitin UK (Turnitin UK Report Processing Time).