Network outage
Incident Report for Turnitin
Resolved
We’ve fixed it!

Due to a network outage experienced by a 3rd party network provider affecting the QuickMarks feature, users of Turnitin, TurnitinUK and those who access the service via an integration may also have been affected.

However, we are pleased to advise that service has been restored.

The degradation occurred between the following times:

PDT: September 28th 10:48 - September 28th 14:00
BST: September 28th 18:48 - September 28th 22:00
AEST: September 29th 03:48 - September 29th 07:00

Please accept our apologies if you were impacted by today’s degradation.
Posted Sep 28, 2022 - 14:19 PDT
Monitoring
Due to a network outage experienced by a 3rd party network provider, users may be unable to access some of Turnitin's grading tools when attempting to access QuickMarks.

We are currently investigating this as a priority and apologize for any inconvenience this may cause.

In the meantime, we invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Sep 28, 2022 - 11:30 PDT
This incident affected: Turnitin (Turnitin Feedback Studio Grading Access) and Turnitin UK (Turnitin UK Feedback Studio Grading Access).