Network Outage
Incident Report for Turnitin
Resolved
Due to an internet wide service issue, users may have been unable to access any of Turnitin’s services, and you may also have found that submissions took longer than expected to generate Similarity Reports. We are pleased to advise that service has been restored.

The incident occurred between the following times:

PDT April 29th 02:04 - April 29th 03:34
BST April 29th 10:04 - April 29th 11:34
AEST April 29th 19:04 - April 29th 20:34

Please accept our apologies if you were impacted by today’s incident.
Posted Apr 29, 2022 - 03:58 PDT
Identified
We are currently investigating an internet wide issue, impacting numerous websites and services, including our own.

During this time, users may be unable to access any of Turnitin’s services, and you may also find that submissions take longer than expected to generate Similarity Reports.

We are currently investigating this as a priority and apologise for any inconvenience this may cause. We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Apr 29, 2022 - 03:11 PDT
This incident affected: Europe (EU environment) (Turnitin Logins, Paper Submissions, Report Processing Time, API), Draft Coach (Draft Coach Paper Submissions, Draft Coach Report Processing Times, API), iThenticate (iThenticate Website, iThenticate Report Processing Time, iThenticate API), Crossref Similarity Check ((v1) Website Logins, (v1) Similarity Reports Generation, (v1) API), Turnitin (Turnitin.com, Turnitin Logins, Turnitin Paper Submissions, Turnitin Report Processing Time, Turnitin Feedback Studio Access, Turnitin Feedback Studio Grading Access), Turnitin UK (Turnitinuk.com, Turnitin UK Logins, Turnitin UK Paper Submissions, Turnitin UK Report Processing Time, Turnitin UK Feedback Studio Access, Turnitin UK Feedback Studio Grading Access), Asia Pacific (Asia Pacific environment) (Turnitin Logins, Paper Submissions, Report Processing Time, API), and Americas (US environment) (Turnitin Logins, Paper Submissions, Report Processing Time, API).